Mobile menu

Stron w wątku:   < [1 2 3]
Severe bug: The context list is null. Could not get the last child.
Autor wątku: EnglishandForm

LegalTransform  Identity Verified
USA
Local time: 16:36
Członek ProZ.com
od 2002

hiszpański > angielski
+ ...
Since this thread has been brought back to life... Apr 29, 2015

... I wanted to add that ever since this first happened to me, whenever I am dealing with an OCR document, the first thing I do before I start translating is attempt to save TARGET AS (blank target segments) to make sure the word document will save correctly.

Direct link Reply with quote
 
Mpoma  Identity Verified
Wielka Brytania
Local time: 21:36
francuski > angielski
Dreadful software Dec 19, 2015

God what rubbish. SDL 2014.

Encountered this error for the first time today... followed the advice about the settings for treatment of Hypertext links, etc. Also tried with a converted Word file. Neither worked.

The formatting of my PDF document is pretty complex, and I suspect this is one origin of the problem. The other being the cr\@pware known as Microsoft software products, and the more recent the cr\@apper it is, IMHO.

What is spectactularly amateurish in the SDL product is that the target generation module, when it "flicks up", can't even tell you the number(s) of the problem segment(s). In my case I could see the generation progress bar getting hesitant around 91%... then it managed to reach 95% ... and then errors appeared.

NB Jeff Whittaker's suggestion about doing a test generation is very sound advice, which I shall henceforth follow systematically

ALTERNATIVE WORKAROUND which may be useful

For anyone tearing out what remains of any hair they may have, and not having found a solution in this thread, I suggest the following:

1) Use Word to convert to the earlier ".doc" format of Word.

Optionally use this procedure:*
1a) Select the whole text of this file
1b) Go Format --> Font --> Character spacing (NB these commands are from Word 2000; there is no doubt a way to do this in the abysmal Word 2013 with its ghastly "ribbons")
1c) Make Scale to 100%, Spacing and Position to "Normal"
1d) On the "Text Effects" tab here, set to "None"
1e) Save this file

2) Having updated the TM you're using so that it overwrites all segments with the segments in the problem .sdlxliff, add the .doc file to the project, prepare, then open.

3) Do a test target generation (as per Jeff Whittaker's suggestion)... hopefully this will work OK.

4) Go through this file making any necessary changes.

5) Generate target translation...

In my case, a file of 7,500 words of French with, as I say, some complex formatting, I found that a number of segments had spurious extra tags (formatting marks), most of which I had managed to correct using the procedure under 1a) above.

* (Geek alert: this explanation is a bit technical)
This procedure is to prevent all sorts of spurious additional tags appearing in the body of the text when the .doc file is converted to .sdlxliff. Disclaimer: THIS MAY NOT APPLY TO YOUR PDF/DOCX. I worked out that this was what I needed to do with my particular PDF because I opened the .doc file produced from the .docx produced by SDL from the PDF in LibreOffice and saved this file as an .fodt file.

.fodt files are basically LibreOffice files ("Open Document" format) in which everything (all their blood and guts) is on display: the full structure of .fodt files is easy to examine using a text editor such as TextPad.

From this I was able to deduce that the spurious tags found were largely due to minor and completely spurious variations in text formatting, which needed to be ironed out in order not to generate these spurious tags when converting to .sdlxliff.



[Edited at 2015-12-20 09:38 GMT]


Direct link Reply with quote
 

Marcia Galdi  Identity Verified
Brazylia
Local time: 17:36
angielski > portugalski
+ ...
Thanks for the help, Mr JRK Jan 11, 2016

JRK wrote:

You should change for "File Types" option from "[Tools]-[Option]-[File Types]-[PDF]-[Common]" before open PDF file or create new project.

Default setting of "Extract hyperlinks:" is "Always process hyperlinks.".
You change to "Extract only hyperlinks text" or "Never process hyperlinks".

After convert to SDLXLIFF file then you should test "Save source as.." before translate.
If you can save "source file(DOC or DOCX file)", it is no problem on SDLXLIFF file before translate.

Best Regards,


Direct link Reply with quote
 

alpia  Identity Verified
Czechy
Local time: 22:36
Członek ProZ.com
od 2010

niemiecki > czeski
+ ...
Many thanks for Mr. JRK....perfect! You saved me:- )))) Jan 27, 2016

Solution Oct 15, 2012

You should change for "File Types" option from "[Tools]-[Option]-[File Types]-[PDF]-[Common]" before open PDF file or create new project.

Default setting of "Extract hyperlinks:" is "Always process hyperlinks.".
You change to "Extract only hyperlinks text" or "Never process hyperlinks".

After convert to SDLXLIFF file then you should test "Save source as.." before translate.
If you can save "source file(DOC or DOCX file)", it is no problem on SDLXLIFF file before translate.
--------------------

perfect solution! many thanks! very helpful.
best regards
Martina


Direct link Reply with quote
 
José Fernández
Local time: 17:36
angielski > hiszpański
+ ...
My two cents Jul 19, 2016

I came across the exact same problem. I tried changing the way Trados handles hyperlinks and that did not work. I then tried working with the DOCX file that was automatically generated when I added the files to the project and I got the same error. What worked for me was to open the DOCX file that was created and save it to DOC (Word 97-2003) in the Save As menu of Word.

Hope that can be of use for someone out there!


Direct link Reply with quote
 

Isabel Estevez Higueras
Hiszpania
Local time: 22:36
Członek ProZ.com
od 2011

francuski > hiszpański
+ ...
Urgent help for message: "The context list is null. Could not get the last child" Aug 20, 2016

Hi!

I'm really desperated! I've been all the long night trying all the solution of this forum without success.

I use Trados 2011. The file PDF has 44 pages. My deadline is today and I don't know what more I can do.

Can somebody help me, please?

Kindly,

Isabel


Direct link Reply with quote
 

GerardoCáceres
Local time: 14:36
hiszpański > angielski
+ ...
I Think I finally fixed it! Mar 22

I know this bug is a couple of years' old and I don't know if anyone other than me still uses Studio 11, but I found a way to fix it! Or well, at least in all the situations where I've used it, it seems to get the job done.
Here's how:

1- Close the error message
2- File>Save As...
3- choose a different location than where the previous SDLXIFF file used to be
4- in that NEW location, also rename the file. Just rename it "1" or "new file" or something short. I think renaming it something short is essential
5- hit SAVE
6- Now save your translation and the problem should now be solved!

I'll be posting this on all the "content null" posts I can find in case it's helpful to anyone else, so if you see it all over Proz, it's not Spam! it's just joy at finally having cracked this pesky S.O.B.!


Direct link Reply with quote
 

Isabel Estevez Higueras
Hiszpania
Local time: 22:36
Członek ProZ.com
od 2011

francuski > hiszpański
+ ...
Thanks Gerardo! Now I use Studio 15. Mar 28

GerardoCáceres wrote:

I know this bug is a couple of years' old and I don't know if anyone other than me still uses Studio 11, but I found a way to fix it! Or well, at least in all the situations where I've used it, it seems to get the job done.
Here's how:

1- Close the error message
2- File>Save As...
3- choose a different location than where the previous SDLXIFF file used to be
4- in that NEW location, also rename the file. Just rename it "1" or "new file" or something short. I think renaming it something short is essential
5- hit SAVE
6- Now save your translation and the problem should now be solved!

I'll be posting this on all the "content null" posts I can find in case it's helpful to anyone else, so if you see it all over Proz, it's not Spam! it's just joy at finally having cracked this pesky S.O.B.!


Direct link Reply with quote
 
caterissimi
Włochy
that's not working....... Apr 20

GerardoCáceres wrote:

I know this bug is a couple of years' old and I don't know if anyone other than me still uses Studio 11, but I found a way to fix it! Or well, at least in all the situations where I've used it, it seems to get the job done.
Here's how:

1- Close the error message
2- File>Save As...
3- choose a different location than where the previous SDLXIFF file used to be
4- in that NEW location, also rename the file. Just rename it "1" or "new file" or something short. I think renaming it something short is essential
5- hit SAVE
6- Now save your translation and the problem should now be solved!

I'll be posting this on all the "content null" posts I can find in case it's helpful to anyone else, so if you see it all over Proz, it's not Spam! it's just joy at finally having cracked this pesky S.O.B.!


Direct link Reply with quote
 
Stron w wątku:   < [1 2 3]


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Severe bug: The context list is null. Could not get the last child.

Advanced search


Translation news related to SDL Trados





SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »
Across v6.3
Translation Toolkit and Sales Potential under One Roof

Apart from features that enable you to translate more efficiently, the new Across Translator Edition v6.3 comprises your crossMarket membership. The new online network for Across users assists you in exploring new sales potential and generating revenue.

More info »



All of ProZ.com
  • All of ProZ.com
  • Szukaj terminu
  • Praca